const regex = /node_modules\/(?!(react-native|my-project|react-native-button)\/)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('node_modules\\\/(?!(react-native|my-project|react-native-button)\\\/)', 'gm')
const str = `/node_modules/react-native/index.js
/node_modules/react-nativeee/index.js
/node_modules/my-project/index.js
/node_modules/my-projector/index.js
/node_modules/my-project-also/index.js
/node_modules/react-native-button/index.js
/node_modules/react-native-buttonholder/index.js
/node_modules/react-native-button-extra/index.js
/foo/bar/baz/node_modules/react-native/index.js
/foo/bar/baz/node_modules/react-nativeee/index.js
/foo/bar/baz/node_modules/my-project/index.js
/foo/bar/baz/node_modules/my-projector/index.js
/foo/bar/baz/node_modules/my-project-also/index.js
/foo/bar/baz/node_modules/react-native-button/index.js
/foo/bar/baz/node_modules/react-native-buttonholder/index.js
/foo/bar/baz/node_modules/react-native-button-extra/index.js
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}