import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "node_modules\\/(?!(react-native|my-project|react-native-button)\\/)";
final String string = "/node_modules/react-native/index.js\n"
+ "/node_modules/react-nativeee/index.js\n"
+ "/node_modules/my-project/index.js\n"
+ "/node_modules/my-projector/index.js\n"
+ "/node_modules/my-project-also/index.js\n"
+ "/node_modules/react-native-button/index.js\n"
+ "/node_modules/react-native-buttonholder/index.js\n"
+ "/node_modules/react-native-button-extra/index.js\n"
+ "/foo/bar/baz/node_modules/react-native/index.js\n"
+ "/foo/bar/baz/node_modules/react-nativeee/index.js\n"
+ "/foo/bar/baz/node_modules/my-project/index.js\n"
+ "/foo/bar/baz/node_modules/my-projector/index.js\n"
+ "/foo/bar/baz/node_modules/my-project-also/index.js\n"
+ "/foo/bar/baz/node_modules/react-native-button/index.js\n"
+ "/foo/bar/baz/node_modules/react-native-buttonholder/index.js\n"
+ "/foo/bar/baz/node_modules/react-native-button-extra/index.js\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}