using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)<!--\s*\*\s*style\s*-->(.+?)<!--\s*/style\s*-->";
string input = @"<!-- *style -->
<style>
.page {
display: grid;
grid-template-columns: repeat(3, 1fr);
grid-template-rows: repeat(7, 13.468%);
align-content: end;
width: var(--w);
aspect-ratio: 210 / 297; /* A4 portrait */
}
</style>
<!-- /style -->
<div class=""page"" style=""[style]"">\r\n[items]
</div>
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}