# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)<!--\s*\*\s*style\s*-->(.+?)<!--\s*/style\s*-->"
test_str = ("<!-- *style -->\n"
"<style>\n"
" .page {\n"
" display: grid;\n"
" grid-template-columns: repeat(3, 1fr);\n"
" grid-template-rows: repeat(7, 13.468%);\n"
" align-content: end;\n"
" width: var(--w);\n"
" aspect-ratio: 210 / 297; /* A4 portrait */\n"
" }\n"
"</style>\n"
"<!-- /style -->\n"
"<div class=\"page\" style=\"[style]\">\\r\\n[items]\n"
"</div>\n\n"
" }")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.