use strict;
my $str = '<!-- *style -->
<style>
.page {
display: grid;
grid-template-columns: repeat(3, 1fr);
grid-template-rows: repeat(7, 13.468%);
align-content: end;
width: var(--w);
aspect-ratio: 210 / 297; /* A4 portrait */
}
</style>
<!-- /style -->
<div class="page" style="[style]">\\r\\n[items]
</div>
}';
my $regex = qr/(?s)<!--\s*\*\s*style\s*-->(.+?)<!--\s*/style\s*-->/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}