import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)<!--\\s*\\*\\s*style\\s*-->(.+?)<!--\\s*/style\\s*-->";
final String string = "<!-- *style -->\n"
+ "<style>\n"
+ " .page {\n"
+ " display: grid;\n"
+ " grid-template-columns: repeat(3, 1fr);\n"
+ " grid-template-rows: repeat(7, 13.468%);\n"
+ " align-content: end;\n"
+ " width: var(--w);\n"
+ " aspect-ratio: 210 / 297; /* A4 portrait */\n"
+ " }\n"
+ "</style>\n"
+ "<!-- /style -->\n"
+ "<div class=\"page\" style=\"[style]\">\\r\\n[items]\n"
+ "</div>\n\n"
+ " }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}