const regex = new RegExp('(?s)<!--\\s*\\*\\s*style\\s*-->(.+?)<!--\\s*/style\\s*-->', 'gm')
const str = `<!-- *style -->
<style>
.page {
display: grid;
grid-template-columns: repeat(3, 1fr);
grid-template-rows: repeat(7, 13.468%);
align-content: end;
width: var(--w);
aspect-ratio: 210 / 297; /* A4 portrait */
}
</style>
<!-- /style -->
<div class="page" style="[style]">\\r\\n[items]
</div>
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}