// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s)<!--\s*\*\s*style\s*-->(.+?)<!--\s*/style\s*-->").unwrap();
let string = "<!-- *style -->
<style>
.page {
display: grid;
grid-template-columns: repeat(3, 1fr);
grid-template-rows: repeat(7, 13.468%);
align-content: end;
width: var(--w);
aspect-ratio: 210 / 297; /* A4 portrait */
}
</style>
<!-- /style -->
<div class=\"page\" style=\"[style]\">\\r\\n[items]
</div>
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}