#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)Teacher_name:[\w\s]+,\s*Remarks:[\w\s]+,\s*"
Local $sString = "Subject_name: English, Teacher_name: John Doe, Remarks: some comment, Overall_marks:87," & @CRLF & _
"Subject_name: Mathematics, Teacher_name: Doe John, Remarks: some comment, Overall_marks:75," & @CRLF & _
"Subject_name: Science, Teacher_name: JD, Remarks: some comment, Overall_marks:80,"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)