import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Teacher_name:[\\w\\s]+,\\s*Remarks:[\\w\\s]+,\\s*";
final String string = "Subject_name: English, Teacher_name: John Doe, Remarks: some comment, Overall_marks:87,\n"
+ "Subject_name: Mathematics, Teacher_name: Doe John, Remarks: some comment, Overall_marks:75,\n"
+ "Subject_name: Science, Teacher_name: JD, Remarks: some comment, Overall_marks:80,";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}