const regex = /Teacher_name:[\w\s]+,\s*Remarks:[\w\s]+,\s*/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Teacher_name:[\\w\\s]+,\\s*Remarks:[\\w\\s]+,\\s*', 'gi')
const str = `Subject_name: English, Teacher_name: John Doe, Remarks: some comment, Overall_marks:87,
Subject_name: Mathematics, Teacher_name: Doe John, Remarks: some comment, Overall_marks:75,
Subject_name: Science, Teacher_name: JD, Remarks: some comment, Overall_marks:80,`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);