using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Teacher_name:[\w\s]+,\s*Remarks:[\w\s]+,\s*";
string substitution = @"";
string input = @"Subject_name: English, Teacher_name: John Doe, Remarks: some comment, Overall_marks:87,
Subject_name: Mathematics, Teacher_name: Doe John, Remarks: some comment, Overall_marks:75,
Subject_name: Science, Teacher_name: JD, Remarks: some comment, Overall_marks:80,";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}