import re
regex = re.compile(r"Teacher_name:[\w\s]+,\s*Remarks:[\w\s]+,\s*", flags=re.IGNORECASE)
test_str = ("Subject_name: English, Teacher_name: John Doe, Remarks: some comment, Overall_marks:87,\n"
"Subject_name: Mathematics, Teacher_name: Doe John, Remarks: some comment, Overall_marks:75,\n"
"Subject_name: Science, Teacher_name: JD, Remarks: some comment, Overall_marks:80,")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)