#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([\+|\@|\#](\w*\s))"
Local $sString = ""+20 @facebook #hashtag with my love""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)