import Foundation
let pattern = ##"([\+|\@|\#](\w*\s))"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##""+20 @facebook #hashtag with my love""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)