re = /([\+|\@|\#](\w*\s))/
str = '"+20 @facebook #hashtag with my love"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result