use strict;
my $str = '"+20 @facebook #hashtag with my love"';
my $regex = qr/([\+|\@|\#](\w*\s))/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";