const regex = /([\+|\@|\#](\w*\s))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\+|\\@|\\#](\\w*\\s))', 'g')
const str = `"+20 @facebook #hashtag with my love"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);