$re = '/([\+|\@|\#](\w*\s))/';
$str = '"+20 @facebook #hashtag with my love"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;