# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<!\[CDATA\[(.*)\]\]>/$1/;t' <<< "<![CDATA[<sender>John Smith</sender>]]>"