use strict;
my $str = '<![CDATA[<sender>John Smith</sender>]]>';
my $regex = qr/<!\[CDATA\[(.*)\]\]>/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";