$re = '/<!\[CDATA\[(.*)\]\]>/';
$str = '<![CDATA[<sender>John Smith</sender>]]>';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;