using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!\[CDATA\[(.*)\]\]>";
string substitution = @"$1";
string input = @"<![CDATA[<sender>John Smith</sender>]]>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}