import re
regex = re.compile(r"<!\[CDATA\[(.*)\]\]>")
test_str = "<![CDATA[<sender>John Smith</sender>]]>"
subst = "$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)