#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:\[QUOTE=)([^\]]+)\]([^\[]+)(?:\[\/QUOTE\])"
Local $sString = "[QUOTE=SOMENAME]Well I tell ya what ....." & @CRLF & _
"Sounds like a great project." & @CRLF & _
"another line for testing" & @CRLF & _
"even more lines." & @CRLF & _
"[/QUOTE]"
Local $sSubst = "$1 said: $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)