import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\[QUOTE=)([^\\]]+)\\]([^\\[]+)(?:\\[\\/QUOTE\\])";
final String string = "[QUOTE=SOMENAME]Well I tell ya what .....\n"
+ "Sounds like a great project.\n"
+ "another line for testing\n"
+ "even more lines.\n"
+ "[/QUOTE]";
final String subst = "$1 said: $2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}