const regex = /(?:\[QUOTE=)([^\]]+)\]([^\[]+)(?:\[\/QUOTE\])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\[QUOTE=)([^\\]]+)\\]([^\\[]+)(?:\\[\\\/QUOTE\\])', '')
const str = `[QUOTE=SOMENAME]Well I tell ya what .....
Sounds like a great project.
another line for testing
even more lines.
[/QUOTE]`;
const subst = `$1 said: $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);