using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[QUOTE=)([^\]]+)\]([^\[]+)(?:\[\/QUOTE\])";
string substitution = @"$1 said: $2";
string input = @"[QUOTE=SOMENAME]Well I tell ya what .....
Sounds like a great project.
another line for testing
even more lines.
[/QUOTE]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}