# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\[QUOTE=)([^\]]+)\]([^\[]+)(?:\[\/QUOTE\])"
test_str = ("[QUOTE=SOMENAME]Well I tell ya what .....\n"
"Sounds like a great project.\n"
"another line for testing\n"
"even more lines.\n"
"[/QUOTE]")
subst = "$1 said: $2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.