$re = '/(?:\[QUOTE=)([^\]]+)\]([^\[]+)(?:\[\/QUOTE\])/';
$str = '[QUOTE=SOMENAME]Well I tell ya what .....
Sounds like a great project.
another line for testing
even more lines.
[/QUOTE]';
$subst = "$1 said: $2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;