// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\[QUOTE=)([^\]]+)\]([^\[]+)(?:\[\/QUOTE\])").unwrap();
let string = "[QUOTE=SOMENAME]Well I tell ya what .....
Sounds like a great project.
another line for testing
even more lines.
[/QUOTE]";
let substitution = "$1 said: $2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}