re = /(?:\[QUOTE=)([^\]]+)\]([^\[]+)(?:\[\/QUOTE\])/
str = '[QUOTE=SOMENAME]Well I tell ya what .....
Sounds like a great project.
another line for testing
even more lines.
[/QUOTE]'
subst = '$1 said: $2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result