#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https:\/\/example\.com$"
Local $sString = "<p>https://google.com</p>" & @CRLF & _
"" & @CRLF & _
"<p>https://clankapp.com</p>" & @CRLF & _
"" & @CRLF & _
"<p>https://yoyo.com</p>" & @CRLF & _
"" & @CRLF & _
"<p>https://example.com</p>" & @CRLF & _
"" & @CRLF & _
"https://example.com" & @CRLF & _
"" & @CRLF & _
"<p>https://javascript.net/pizza</p>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")