using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https:\/\/example\.com$";
string input = @"<p>https://google.com</p>
<p>https://clankapp.com</p>
<p>https://yoyo.com</p>
<p>https://example.com</p>
https://example.com
<p>https://javascript.net/pizza</p>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}