import re
regex = re.compile(r"^https:\/\/example\.com$", flags=re.MULTILINE)
test_str = ("<p>https://google.com</p>\n\n"
"<p>https://clankapp.com</p>\n\n"
"<p>https://yoyo.com</p>\n\n"
"<p>https://example.com</p>\n\n"
"https://example.com\n\n"
"<p>https://javascript.net/pizza</p>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")