$re = '/^https:\/\/example\.com$/m';
$str = '<p>https://google.com</p>
<p>https://clankapp.com</p>
<p>https://yoyo.com</p>
<p>https://example.com</p>
https://example.com
<p>https://javascript.net/pizza</p>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);