# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\S+\h\S+\K\h/\n/gm;t' <<< "20 DE NOVIEMBRE
CENTRO
EL ARENAL 4A SECCION
IGNACIO ZARAGOZA
JARDIN BALBUENA
MOCTEZUMA 2A SECCION
MORELOS
PEON DE LOS BAOS"