re = /^\S+\h\S+\K\h/m
str = '20 DE NOVIEMBRE
CENTRO
EL ARENAL 4A SECCION
IGNACIO ZARAGOZA
JARDIN BALBUENA
MOCTEZUMA 2A SECCION
MORELOS
PEON DE LOS BAOS'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result