const regex = /^\S+\h\S+\K\h/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\S+\\h\\S+\\K\\h', 'gm')
const str = `20 DE NOVIEMBRE
CENTRO
EL ARENAL 4A SECCION
IGNACIO ZARAGOZA
JARDIN BALBUENA
MOCTEZUMA 2A SECCION
MORELOS
PEON DE LOS BAOS`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);