use strict;
my $str = '20 DE NOVIEMBRE
CENTRO
EL ARENAL 4A SECCION
IGNACIO ZARAGOZA
JARDIN BALBUENA
MOCTEZUMA 2A SECCION
MORELOS
PEON DE LOS BAOS';
my $regex = qr/^\S+\h\S+\K\h/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";