$re = '/^\S+\h\S+\K\h/m';
$str = '20 DE NOVIEMBRE
CENTRO
EL ARENAL 4A SECCION
IGNACIO ZARAGOZA
JARDIN BALBUENA
MOCTEZUMA 2A SECCION
MORELOS
PEON DE LOS BAOS';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;