import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\S+\\h\\S+\\K\\h";
final String string = "20 DE NOVIEMBRE\n"
+ "CENTRO\n"
+ "EL ARENAL 4A SECCION\n"
+ "IGNACIO ZARAGOZA\n"
+ "JARDIN BALBUENA\n"
+ "MOCTEZUMA 2A SECCION\n"
+ "MORELOS\n"
+ "PEON DE LOS BAOS";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}