#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\S+\h\S+\K\h"
Local $sString = "20 DE NOVIEMBRE" & @CRLF & _
"CENTRO" & @CRLF & _
"EL ARENAL 4A SECCION" & @CRLF & _
"IGNACIO ZARAGOZA" & @CRLF & _
"JARDIN BALBUENA" & @CRLF & _
"MOCTEZUMA 2A SECCION" & @CRLF & _
"MORELOS" & @CRLF & _
"PEON DE LOS BAOS"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)