# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ *(.*) +?\n*$/$1/mg;t' <<< "first line... abc
second is here... def
fourth line... hi there
sith is here.... "