$re = '/ *(.*) +?\n*$/m';
$str = 'first line... abc
second is here... def
fourth line... hi there
sith is here.... ';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;