use strict;
my $str = 'first line... abc
second is here... def
fourth line... hi there
sith is here.... ';
my $regex = qr/ *(.*) +?\n*$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";