const regex = / *(.*) +?\n*$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' *(.*) +?\\n*$', 'mg')
const str = `first line... abc
second is here... def
fourth line... hi there
sith is here.... `;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);