using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" *(.*) +?\n*$";
string substitution = @"$1";
string input = @"first line... abc
second is here... def
fourth line... hi there
sith is here.... ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}