re = / *(.*) +?\n*$/m
str = 'first line... abc
second is here... def
fourth line... hi there
sith is here.... '
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result