package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) *(.*) +?\n*$`)
var str = `first line... abc
second is here... def
fourth line... hi there
sith is here.... `
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}